Medchat - System outage – Incident details

System outage

Resolved
Major outage
Started about 2 months agoLasted about 2 hours

Affected

Authentication

Major outage from 10:11 PM to 10:39 PM, Operational from 10:39 PM to 11:55 PM

Medchat Auth Application

Major outage from 10:11 PM to 10:39 PM, Operational from 10:39 PM to 11:55 PM

Google SSO

Major outage from 10:11 PM to 10:39 PM, Operational from 10:39 PM to 11:55 PM

Custom OIDC SSO

Major outage from 10:11 PM to 10:39 PM, Operational from 10:39 PM to 11:55 PM

Custom SAML SSO

Major outage from 10:11 PM to 10:39 PM, Operational from 10:39 PM to 11:55 PM

Live Chat

Major outage from 10:11 PM to 10:39 PM, Operational from 10:39 PM to 11:55 PM

Updates
  • Resolved
    Resolved

    We will continue to monitor the system to ensure operational status. Medchat will perform a more detailed analysis of the root cause within the next 24 hours.

  • Monitoring
    Monitoring

    Around 4:11 PM CST, Medchat's authentication service became unresponsive after a planned release. The team identified widespread database connection issues in one application. After initial triage, Medchat reverted to the previous application versions, which resulted in the system becoming responsive again around 4:39 PM CST.

  • Identified
    Identified

    Around 4:11 PM CST, Medchat's authentication service became unresponsive after a planned release. The team identified widespread database connection issues in one application. After initial triage, Medchat reverted to the previous application versions, which resulted in the system becoming responsive again around 4:39 PM CST.