Medchat - System performance – Incident details

System performance

Resolved
Major outage
Started about 2 months agoLasted about 2 hours

Affected

Authentication

Major outage from 4:00 PM to 5:45 PM, Operational from 5:45 PM to 6:11 PM

Medchat Auth Application

Major outage from 4:00 PM to 5:45 PM, Operational from 5:45 PM to 6:11 PM

Google SSO

Major outage from 4:00 PM to 5:45 PM, Operational from 5:45 PM to 6:11 PM

Custom OIDC SSO

Major outage from 4:00 PM to 5:45 PM, Operational from 5:45 PM to 6:11 PM

Custom SAML SSO

Major outage from 4:00 PM to 5:45 PM, Operational from 5:45 PM to 6:11 PM

Live Chat

Major outage from 4:00 PM to 5:45 PM, Operational from 5:45 PM to 6:11 PM

Updates
  • Postmortem
    Postmortem

    Root cause was due to the application's capacity limits as a result of a recent increase in traffic. The system was operating as expected but required additional resources to support the elevated load.

    Resolution was to scale out the app's Azure infrastructure to accommodate the increased demand. Services have since stabilized, and team is continuing to monitor performance closely to ensure continued reliability.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We have implemented mitigations to return to normal operations. We will continue to monitor the system over the next few hours to ensure all components are fully functional.

  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating
    We are currently investigating this incident.